diff --git a/Makefile b/Makefile
index fdf0cae..4c58098 100644
--- a/Makefile
+++ b/Makefile
@@ -26,6 +26,8 @@ $(SUBDIRS)::
 	$(MAKE) -C $@ $(MAKECMDGOALS)
 
 all clean install uninstall: $(SUBDIRS)
+	install -D lv2/b_synth /zynthian/zynthian-plugins/lv2/b_synth
+	install -D lv2/b_whirl /zynthian/zynthian-plugins/lv2/b_whirl
 
 doc:
 	help2man -N --help-option=-H -n 'DSP tonewheel organ' -o doc/setBfree.1 src/setBfree
diff --git a/common.mak b/common.mak
index 0e2f72b..5e76823 100644
--- a/common.mak
+++ b/common.mak
@@ -1,7 +1,7 @@
 # TODO include this only once and export variables
 
 PREFIX ?= /usr/local
-OPTIMIZATIONS ?= -msse -msse2 -mfpmath=sse -ffast-math -fomit-frame-pointer -O3 -fno-finite-math-only
+OPTIMIZATIONS ?= -mcpu=cortex-a53 -mtune=cortex-a53 -mfpu=neon-fp-armv8 -mneon-for-64bits -mfloat-abi=hard -mlittle-endian -munaligned-access -mvectorize-with-neon-quad -ftree-vectorize -ffast-math -fomit-frame-pointer -O3 -fno-finite-math-only
 ENABLE_CONVOLUTION ?= no
 INSTALL_EXTRA_LV2 ?= no
 FONTFILE?=/usr/share/fonts/truetype/ttf-bitstream-vera/VeraBd.ttf
@@ -20,7 +20,7 @@ LV2VERSION=$(VERSION)
 
 bindir = $(PREFIX)/bin
 sharedir = $(PREFIX)/share/setBfree
-lv2dir = $(PREFIX)/lib/lv2
+lv2dir = $(DESTDIR)/zynthian/zynthian-sw/setBfree/lv2
 
 CFLAGS ?= $(OPTIMIZATIONS) -Wall
 ifeq ($(XWIN),)